Production system latency 10/14/2025

Incident Report for Vesta

Resolved

Hi everyone,

The system latency has been resolved.

Cheers,
Eric
Posted Oct 14, 2025 - 12:17 PDT

Investigating

Hi everyone,

We are aware of latency issues affecting the production environments and the team is currently working to resolve. We will continue to keep you posted with updates.

Cheers,
Vesta Support
Posted Oct 14, 2025 - 09:37 PDT
This incident affected: Vesta Production Environments.