Production latency - 8/17

Incident Report for Vesta

Postmortem

Elevated Latency and Errors

Date: August 17, 2026
Duration: 10:28 AM – 10:55 AM PDT
Impact: Users experienced elevated latency and errors throughout the platform.

Summary

The incident was caused by a specific database query used by the version history feed on the process version page. That query reads the entire change history for a process version with no limit and sorts it — in this instance, hundreds of thousands of rows in a single call. During the incident window, this query consumed enough database capacity to create contention for other application queries. As a result, unrelated workflows that depended on the same production database also slowed down or timed out.

Resolution and Next Steps

We will be optimizing this feature, and have updated our database timeouts as a backstop.

Timeline (Pacific Time)

10:28 AM — Specific request to process version history made; database slowdown begins, latency starts to climb

10:31 AM — Database connection capacity exhausted; requests begin failing

10:52 AM — Database-level mitigation applied to update timeouts

10:55 AM — Full recovery

Posted Aug 18, 2026 - 14:53 PDT

Resolved

Hi everyone,

This is fully recovered and the system is functioning normally.

Cheers,
Vesta Support
Posted Aug 17, 2026 - 14:39 PDT

Monitoring

Performance is back to normal and we've implemented additional measures we believe should prevent a recurrence of this issue.
Posted Aug 17, 2026 - 11:19 PDT

Update

We are continuing to investigate this issue.
Posted Aug 17, 2026 - 11:12 PDT

Update

The latency is recovering and we are seeing improvement across the platform. We are continuing to monitor this.
Posted Aug 17, 2026 - 11:11 PDT

Investigating

Hi everyone,

We're currently investigating an issue affecting our prod environments attributed to increased latency. Our team is actively working on identifying the root cause.

We'll post updates here as soon as we have more information.

Cheers,
Vesta Support
Posted Aug 17, 2026 - 10:41 PDT
This incident affected: Production Environment (Core Platform).