Production latency 02/18

Incident Report for Vesta

Resolved

Service is back to normal and this incident is now resolved. We'll share an RCA once we have finished the analysis.
Posted Feb 18, 2026 - 10:42 PST

Investigating

Hi everyone,

We are seeing increased latency in production environments. We are currently investigating and will continue to post updates.

Cheers,
Vesta Support
Posted Feb 18, 2026 - 08:53 PST
This incident affected: Production Environment (Core Platform).