Degraded performance and access issues in Vesta production starting at 12:00 PM CT on June 26th

Incident Report for Vesta

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 11:38 PDT

Monitoring

We began experiencing degraded performance in Vesta production at 12:00 PM CT. We began recovering at 12:03 PM CT, and we're fully recovered at about 12:20 PM CT. We're continuing to monitor and investigating the root cause.
Posted Jun 26, 2026 - 10:45 PDT
This incident affected: Production Environment (Core Platform, Objectives & Field Computation).