Production performance issues 10/17/2025

Incident Report for Vesta

Resolved

Hi everyone,

After maintenance this weekend, we expect the latency issues to be resolved. Please report any latency issues you encounter.

Cheers,
Vesta Support
Posted Oct 20, 2025 - 10:29 PDT

Monitoring

Hi everyone,

We've made some minor updates that should mitigate the performance issues that we experienced this morning. We are continuing to monitor the situation. Please report any performance issues you experience to support@vesta.com or through your normal channels.

Cheers,
Vesta Support
Posted Oct 17, 2025 - 08:21 PDT

Identified

Hi everyone,

We've identified the root cause of the recent instability in our systems. The issue stems from a configuration miscalculation introduced during last night's rollout of larger database node sizes. While automatic failover occurred as expected, the underlying configuration values are still being recalibrated to ensure long-term stability.

At this time, systems are operational but not yet fully recovered. Our engineering team is actively validating new configuration parameters to prevent recurrence under higher load conditions. If necessary, we may perform a brief maintenance event later today to apply these corrections and ensure full recovery.

We'll continue to provide updates as we make progress.

Cheers,
Vesta Support
Posted Oct 17, 2025 - 07:35 PDT

Investigating

Hi everyone,

We are currently experiencing some issues with our production environments. You may notices issues with logging in, pipelines and general application loading. We are urgently addressing this issue and will keep you posted.

Cheers,
Vesta Support
Posted Oct 17, 2025 - 07:02 PDT
This incident affected: Vesta Production Environments.